summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-08 15:22:58 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 11:56:36 +0200
commit49a106f14e7c7db60643125b972d4634ca5647f1 (patch)
tree1d96709b4a98c0d41e2ca612d311311dffed70ff /gnu/packages/ocaml.scm
parent5e448f5f94dcfe6f5c31f963f93177454cc533a1 (diff)
downloadguix-49a106f14e7c7db60643125b972d4634ca5647f1.tar.gz
gnu: Add ocaml-base-quickcheck.
* gnu/packages/ocaml.scm (ocaml-base-quickcheck): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ec2d8ab12e..a57ec2b05f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6614,6 +6614,39 @@ cryptographic-quality randomness in favor of performance.")
       (properties '())
       (license license:asl2.0))))
 
+(define-public ocaml-base-quickcheck
+  (package
+    (name "ocaml-base-quickcheck")
+    (version "0.14.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/janestreet/base_quickcheck")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "0apq3d9xb0zdaqsl4cjk5skyig57ff1plndb2mh0nn3czvfhifxs"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+      (list ocaml-base
+            ocaml-ppx-base
+            ocaml-ppx-fields-conv
+            ocaml-ppx-let
+            ocaml-ppx-sexp-message
+            ocaml-ppx-sexp-value
+            ocaml-splittable-random
+            ocaml-ppxlib))
+    (properties `((upstream-name . "base_quickcheck")))
+    (home-page "https://github.com/janestreet/base_quickcheck")
+    (synopsis
+      "Randomized testing framework, designed for compatibility with Base")
+    (description
+      "@samp{base-quickcheck} provides randomized testing in the style of
+Haskell's Quickcheck library, with support for built-in types as well as
+types provided by Base.")
+    (license license:expat)))
+
 (define-public ocaml4.07-jane-street-headers
   (package
     (name "ocaml4.07-jane-street-headers")