summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-08 15:22:48 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 11:56:15 +0200
commitbee0de9365d24387f7961d6acbfc7acd4d474ead (patch)
tree08e178819348eb8baf1d8c67d00d9e79c5ef96d3 /gnu/packages/ocaml.scm
parentca36468083362b5dcad00f144a1cb83123117cbb (diff)
downloadguix-bee0de9365d24387f7961d6acbfc7acd4d474ead.tar.gz
gnu: Add ocaml-ppx-stable.
* gnu/packages/ocaml.scm (ocaml-ppx-stable): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f8f815b358..d202d45474 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6270,6 +6270,30 @@ from type definitions.")
     (description "This extension provides a syntax for string interpolation.")
     (license license:expat)))
 
+(define-public ocaml-ppx-stable
+  (package
+    (name "ocaml-ppx-stable")
+    (version "0.14.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/janestreet/ppx_stable")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1sp1kn23qr0pfypa4ilvhqq5y11y13xpfygfl582ra9kik5xqfa1"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:test-target "tests"))
+    (propagated-inputs (list ocaml-base ocaml-ppxlib))
+    (properties `((upstream-name . "ppx_stable")))
+    (home-page "https://github.com/janestreet/ppx_stable")
+    (synopsis "Stable types conversions generator")
+    (description "This package is a ppx extension for easier implementation of
+conversion functions between almost identical types.")
+    (license license:expat)))
+
 (define-public ocaml-ppx-base
   (package
     (name "ocaml-ppx-base")