summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:06:18 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:11:02 +0100
commitc56a00a90fada361e2b534f868c9b44a1da552d0 (patch)
tree9585b792506c5ed77d59a3229bf58936d2caa298 /gnu/packages/ocaml.scm
parent7c44828fab9f1c32eb564749d472242df63573f3 (diff)
downloadguix-c56a00a90fada361e2b534f868c9b44a1da552d0.tar.gz
gnu: Remove ocaml4.07-ppx-let.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-let): Remove variable.
(ocaml-ppx-let)[properties]: Remove variant.

Change-Id: Ia173d6bd784b6c1347c3ec2e3cc4e10b9537b092
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a32d64bf6b..6688f6c52b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7213,25 +7213,13 @@ size, the version of the compiler, ...")
     (build-system dune-build-system)
     (propagated-inputs
      (list ocaml-base ocaml-migrate-parsetree ocaml-ppxlib ocaml-ppx-here))
-    (properties `((upstream-name . "ppx_let")
-                  (ocaml4.07-variant . ,(delay ocaml4.07-ppx-let))))
+    (properties `((upstream-name . "ppx_let")))
     (home-page "https://github.com/janestreet/ppx_let")
     (synopsis "Monadic let-bindings")
     (description "A ppx rewriter for monadic and applicative let bindings,
 match expressions, and if expressions.")
     (license license:asl2.0)))
 
-(define-public ocaml4.07-ppx-let
-  (package-with-ocaml4.07
-   (package
-     (inherit ocaml-ppx-let)
-     (version "0.11.0")
-     (source
-      (janestreet-origin "ppx_let" version
-                         "1wdfw6w4xbg97a35yg6bif9gggxniy9ddnrjfw1a0inkl2yamxkj"))
-
-     (properties `((upstream-name . "ppx_let"))))))
-
 (define-public ocaml-ppx-fail
   (package
     (name "ocaml-ppx-fail")