summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-24 14:23:23 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:09:59 +0100
commitda9771c0f295b2e343465216e5fe18f244e40d56 (patch)
tree6d73743432574a49c49e546b7888c0e60f16544f /gnu/packages/ocaml.scm
parent71b29cfac94cd33c4f3a989ef2f49d9c00fbce0d (diff)
downloadguix-da9771c0f295b2e343465216e5fe18f244e40d56.tar.gz
gnu: Remove ocaml4.07-spawn.
* gnu/packages/ocaml.scm (ocaml4.07-spawn): Remove variable.
(ocaml-spawn)[properties]: Remove variant.

Change-Id: Ib655eca9b305de23aa0cee0e29e51d9acea01094
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f99135d2e3..092272c08d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8092,8 +8092,6 @@ Configurator allows one to:
     (build-system dune-build-system)
     (propagated-inputs (list ocaml-odoc))
     (native-inputs (list ocaml-ppx-expect))
-    (properties
-     `((ocaml4.07-variant . ,(delay ocaml4.07-spawn))))
     (home-page "https://github.com/janestreet/spawn")
     (synopsis "Spawning sub-processes")
     (description
@@ -8115,35 +8113,6 @@ thousands of times faster than fork.
 @end itemize")
     (license license:asl2.0)))
 
-(define-public ocaml4.07-spawn
-  (package-with-ocaml4.07
-    (package
-      (inherit ocaml-spawn)
-      (version "0.13.0")
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/janestreet/spawn")
-                       (commit (string-append "v" version))))
-                (file-name (git-file-name "ocaml4.07-spawn" version))
-                (sha256
-                 (base32
-                  "1w003k1kw1lmyiqlk58gkxx8rac7dchiqlz6ah7aj7bh49b36ppf"))))
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-before 'check 'fix-tests
-             (lambda _
-               (substitute* "test/tests.ml"
-                 (("/bin/pwd") (which "pwd"))
-                 (("/bin/echo") (which "echo")))
-               #t)))
-         #:ocaml ,ocaml-4.07
-         #:findlib ,ocaml4.07-findlib
-         #:dune ,ocaml4.07-dune))
-      (propagated-inputs '())
-      (properties '()))))
-
 (define-public ocaml-core
   (package
     (name "ocaml-core")