summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-20 14:11:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 17:08:37 +0100
commit5a3fcf0cac7bdd6b2e82bb72cca4530a996606af (patch)
treea570b681bfb4732fbb58b5a9ac8df465e82fd1d5 /gnu/packages/ocaml.scm
parent40f7eb975b2956a46e467133c6bac4a12e98cfac (diff)
downloadguix-5a3fcf0cac7bdd6b2e82bb72cca4530a996606af.tar.gz
gnu: ocaml-sedlex: Update to 2.4.
* gnu/packages/ocaml.scm (ocaml-sedlex): Update to 2.4.
[native-inputs]: Remove ocamlbuild.
[propagated-inputs]: Remove ocaml-ppx-tools-versioned.
(ocaml4.07-sedlex)[propagated-inputs]: Add ocaml-ppx-tools-versioned.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 52676b7078..d1356f5a2d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2722,7 +2722,7 @@ and consumable.")
 (define-public ocaml-sedlex
   (package
     (name "ocaml-sedlex")
-    (version "2.3")
+    (version "2.4")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2731,7 +2731,7 @@ and consumable.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0iw3phlaqr27jdf857hmj5v5hdl0vngbb2h37p2ll18sw991fxar"))))
+                "13g8az4zqg6hrnxmy3qrasslppzlag13dd1dsr8vlpg2vpfmfv6i"))))
     (build-system dune-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
@@ -2755,12 +2755,9 @@ and consumable.")
            (lambda _
              (for-each (lambda (file) (chmod file #o644)) (find-files "." ".*"))
              #t)))))
-    (native-inputs
-     `(("ocamlbuild" ,ocamlbuild)))
     (propagated-inputs
      `(("ocaml-gen" ,ocaml-gen)
        ("ocaml-ppxlib" ,ocaml-ppxlib)
-       ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
        ("ocaml-uchar" ,ocaml-uchar)))
     ;; These three files are needed by src/generator/data/dune, but would be
     ;; downloaded using curl at build time.
@@ -2807,6 +2804,9 @@ and consumable.")
                (sha256
                 (base32
                  "05f6qa8x3vhpdz1fcnpqk37fpnyyq13icqsk2gww5idjnh6kng26"))))
+     (propagated-inputs
+      `(("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
+        ,@(package-propagated-inputs ocaml-sedlex)))
      (properties '()))))
 
 (define-public ocaml-uchar