summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-06 20:56:19 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-06 20:56:19 -0600
commit136919ba4976ec20bbfbd14587e87c4780653226 (patch)
tree38bbe4ec99af1eb2c0b22f9c9c158fab7d65c5de /gnu/packages/ocaml.scm
parentc4970c53a6f9ce1b1d54c0bd59d62a4507f55b5b (diff)
downloadguix-136919ba4976ec20bbfbd14587e87c4780653226.tar.gz
gnu: Add ocaml-cairo2.
* gnu/packages/ocaml.scm (ocaml-cairo2): New variable.

Co-authored-by: Julien Lepiller <julien@lepiller.eu>.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a9e421a17c..738706b23f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5243,3 +5243,33 @@ library FFTW.")
 LAPACK-library (Linear Algebra routines).  It also contains many additional
 convenience functions for vectors and matrices.")
     (license license:lgpl2.1)))
+
+(define-public ocaml-cairo2
+  (package
+    (name "ocaml-cairo2")
+    (version "0.6.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Chris00/ocaml-cairo.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0wzysis9fa850s68qh8vrvqc6svgllhwra3kzll2ibv0wmdqrich"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:test-target "tests"))
+    (inputs
+     `(("cairo" ,cairo)
+       ("gtk+-2" ,gtk+-2)
+       ("lablgtk" ,lablgtk)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/Chris00/ocaml-cairo")
+    (synopsis "Binding to Cairo, a 2D Vector Graphics Library")
+    (description "Ocaml-cairo2 is a binding to Cairo, a 2D graphics library
+with support for multiple output devices.  Currently supported output targets
+include the X Window System, Quartz, Win32, image buffers, PostScript, PDF,
+and SVG file output.")
+    (license license:lgpl3+)))