summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-02-06 19:30:24 +0100
committerJulien Lepiller <julien@lepiller.eu>2022-02-06 21:41:54 +0100
commitc8b5f9daf5a5aed503c70ed7b3477d4edfd4f523 (patch)
tree4949aebe821c6dbc27b9b9382c02d01eb121ca5a /gnu/packages/ocaml.scm
parent7c9ad54b0616112c7eea6dd02379616aef206490 (diff)
downloadguix-c8b5f9daf5a5aed503c70ed7b3477d4edfd4f523.tar.gz
gnu: ocaml-qcheck: Update to 0.18.1.
* gnu/packages/ocaml.scm (ocaml-qcheck): Update to 0.18.1.
* gnu/packages/patches/ocaml-qcheck-fix-test-whitespace.patch: Remove
file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 150ce3157f..6b743f8892 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1548,7 +1548,7 @@ archive(native) = \"frontc.cmxa\""))))
 (define-public ocaml-qcheck
   (package
     (name "ocaml-qcheck")
-    (version "0.18")
+    (version "0.18.1")
     (source
      (origin
        (method git-fetch)
@@ -1556,19 +1556,11 @@ archive(native) = \"frontc.cmxa\""))))
              (url "https://github.com/c-cube/qcheck")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
-       (patches (search-patches "ocaml-qcheck-fix-test-whitespace.patch"))
        (sha256
-        (base32 "1s652hrj2sxqj30dfl300zjvvqk3r62a1bnzqw1hqyf6pi88qn8x"))))
+        (base32 "0g3r8lrw6fsdphgpnp08saxyxk1vd3chpmb564ir2qnsp716vz6z"))))
     (build-system dune-build-system)
     (arguments
-     `(#:test-target "."
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'fix-deprecated
-           (lambda _
-             (substitute* "src/core/QCheck.ml"
-               (("Pervasives.compare") "compare"))
-             #t)))))
+     `(#:test-target "."))
     (propagated-inputs
      (list ocaml-alcotest ocaml-ounit))
     (native-inputs