summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorPeter Kreye <kreyepr@gmail.com>2018-01-13 05:25:52 -0600
committerJulien Lepiller <julien@lepiller.eu>2018-02-01 23:09:21 +0100
commitc98c82370462f8c06c420175dcc47fc1a64cf68d (patch)
tree093b21e25fe6f8b5aa96b3d38bfbf74e8ea61138 /gnu/packages/ocaml.scm
parent69d08bb131c507550643d33e63526c00ed8c0e43 (diff)
downloadguix-c98c82370462f8c06c420175dcc47fc1a64cf68d.tar.gz
gnu: Add ocaml-ocb-stubblr.
* gnu/packages/ocaml.scm (ocaml-ocb-stubblr): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 021dabf835..1ecd9ab540 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3811,6 +3811,38 @@ functions that you want to call, then bind directly to those functions -- all
 without writing or generating any C!")
    (license license:expat)))
 
+(define-public ocaml-ocb-stubblr
+  (package
+   (name "ocaml-ocb-stubblr")
+   (version "0.1.1")
+   (home-page "https://github.com/pqwy/ocb-stubblr")
+   (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   home-page "/releases/download/v0.1.1/ocb-stubblr-"
+                   version ".tbz"))
+             (file-name (string-append name "-" version ".tbz"))
+             (sha256
+              (base32
+               "167b7x1j21mkviq8dbaa0nmk4rps2ilvzwx02igsc2706784z72f"))))
+   (build-system ocaml-build-system)
+   (arguments
+    `(#:findlib ,ocaml-findlib-1.7.3
+      #:build-flags (list "build" "--tests" "true")
+      #:phases
+      (modify-phases %standard-phases
+        (delete 'configure))))
+   (inputs
+    `(("topkg" ,ocaml-topkg)
+      ("opam", opam)))
+   (native-inputs
+    `(("astring" ,ocaml-astring)))
+   (synopsis "OCamlbuild plugin for C stubs")
+   (description "Ocb-stubblr is about ten lines of code that you need to
+repeat over, over, over and over again if you are using ocamlbuild to build
+OCaml projects that contain C stubs.")
+   (license license:isc)))
+
 (define-public coq-flocq
   (package
     (name "coq-flocq")