summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 16:35:13 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-02-15 20:10:42 +0100
commitf6dde36aebb9a955c8f1dd1db30d43b5955e0084 (patch)
tree9c46c7d3403919dde8304d9a9d51abe7e100aa0f /gnu/packages/ocaml.scm
parent9e5687867da327f8d1993b83392324e6e16679ed (diff)
downloadguix-f6dde36aebb9a955c8f1dd1db30d43b5955e0084.tar.gz
gnu: Add ocaml-cppo.
* gnu/packages/ocaml.scm (ocaml-cppo): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 83d2632f17..23ef7cca4a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2117,3 +2117,33 @@ provide a tool that can be used to:
 @item improved errors for misspelled/misplaced attributes and extension points.
 @end enumerate")
     (license license:asl2.0)))
+
+(define-public ocaml-cppo
+  (package
+    (name "ocaml-cppo")
+    (version "1.4.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://github.com/mjambon/cppo/archive/v" version
+                            ".tar.gz"))
+        (sha256 (base32
+                  "02gma6nw09vfnd6h7bl3n70lwz7m9z2svplxyfh6h5bf4lqgqzjv"))
+        (file-name (string-append name "-" version ".tar.gz"))))
+    (build-system ocaml-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases (delete 'configure))
+       #:make-flags (list (string-append "BINDIR="
+                                         (assoc-ref %outputs "out") "/bin"))
+       #:tests? #f))
+    (home-page "https://github.com/mjambon/cppo")
+    (synopsis "Equivalent of the C preprocessor for OCaml programs")
+    (description "Cppo is an equivalent of the C preprocessor for OCaml
+programs.  It allows the definition of simple macros and file inclusion.  Cpp ois:
+@enumerate
+@item more OCaml-friendly than cpp
+@item easy to learn without consulting a manual
+@item reasonably fast
+@item simple to install and to maintain.
+@end enumerate")
+    (license license:bsd-3)))