summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2023-01-13 10:54:40 +0000
committerJulien Lepiller <julien@lepiller.eu>2023-01-15 15:57:42 +0100
commit2a08065b051e42836cd46da0876ac2b2b6ee7733 (patch)
tree3fe69bed1ea531cdd3431c9a0f338966e4946393 /gnu/packages/ocaml.scm
parent386ad7d8d14dee2103927d3f3609acc63373156a (diff)
downloadguix-2a08065b051e42836cd46da0876ac2b2b6ee7733.tar.gz
gnu: ocaml-ppx-expect: Disable tests.
Tests require a package that would cause a cyclic dependency after
removing test-target.

* gnu/packages/ocaml.scm (ocaml-ppx-expect): Disable tests.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7b59bee28f..29ce615dfe 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7043,6 +7043,9 @@ useful errors on failure.")
         (base32
          "134dl5qhjxsj2mcmrx9f3m0iys0n5mjfpz9flj8zn8d2jir43776"))))
     (build-system dune-build-system)
+    (arguments
+     ;; Cyclic dependency with ocaml-ppx-jane
+     `(#:tests? #f))
     (propagated-inputs
      (list ocaml-base
            ocaml-ppx-here