summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 19:40:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-31 20:32:50 +0200
commit4a7243fcfb1aa6f967a16cb31510aa421012fd56 (patch)
tree1c5486227f6715308ea1c14b87b96f0dadea37dd /gnu/packages/ocaml.scm
parent55d6b357a937166ba19beb036b87519293e3bc2d (diff)
downloadguix-4a7243fcfb1aa6f967a16cb31510aa421012fd56.tar.gz
gnu: ocamlify: Parametrize source URI.
* gnu/packages/ocaml.scm (ocamlify)[source]: Construct with VERSION.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 682bc890bf..df1ca764aa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2259,18 +2259,18 @@ radix-64 representation.  It is specified in RFC 4648.")
   (package
     (name "ocamlify")
     (version "0.0.1")
-    (source (origin
-              (method url-fetch)
-              (uri "https://download.ocamlcore.org/ocamlify/ocamlify/0.0.1/ocamlify-0.0.1.tar.gz")
-              (sha256
-               (base32
-                "1j9nb3vjqbdsx3d6jazixgrh776051zkrc06nsc5q5ilp1jhrwkm"))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://download.ocamlcore.org/ocamlify/ocamlify/"
+                           version "/ocamlify-" version ".tar.gz"))
+       (sha256
+        (base32 "1j9nb3vjqbdsx3d6jazixgrh776051zkrc06nsc5q5ilp1jhrwkm"))))
     (build-system ocaml-build-system)
-    ; tests are done during build
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (delete 'check)
+         (delete 'check)                ; tests are run during the build
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (invoke "ocaml" "setup.ml" "-configure" "--prefix"