summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 22:59:55 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:54 +0000
commit8b62d9403ea79ce21d7ef036c4edc3faaa2885bb (patch)
treee9faf1de87b1b21f0fc87bfcec0179b8a7df1191 /gnu/packages/ocaml.scm
parent9ca7804aafe3a8560a492c561969e8dd39630ed5 (diff)
downloadguix-8b62d9403ea79ce21d7ef036c4edc3faaa2885bb.tar.gz
gnu: Add ocaml-emile.
* gnu/packages/ocaml.scm (ocaml-emile): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 17230b5023..f6371983d3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3648,6 +3648,33 @@ according to RFC2045 and RFC2047 (about encoded-word).  Useful to translate
 contents of emails.")
     (license license:expat)))
 
+(define-public ocaml-emile
+  (package
+    (name "ocaml-emile")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              (uri
+               "https://github.com/mirage/emile/releases/download/v1.1/emile-v1.1.tbz")
+              (sha256
+               (base32
+                "0r1141makr0b900aby1gn0fccjv1qcqgyxib3bzq8fxmjqwjan8p"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-angstrom
+                             ocaml-ipaddr
+                             ocaml-base64
+                             ocaml-pecu
+                             ocaml-bigstringaf
+                             ocaml-uutf))
+    (native-inputs (list ocaml-alcotest))
+    (home-page "https://github.com/mirage/emile")
+    (synopsis "Parser of email address according RFC822")
+    (description
+     "This package provides a parser of email address according RFC822, RFC2822,
+RFC5321 and RFC6532.  It handles UTF-8 email addresses and encoded-word
+according RFC2047.")
+    (license license:expat)))
+
 (define-public ocaml-ocurl
   (package
     (name "ocaml-ocurl")