summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-17 00:41:20 -0600
committerEric Bavier <bavier@member.fsf.org>2016-01-17 01:04:43 -0600
commitf5a8491b6983087fe85002a7b6435119332892c2 (patch)
tree7b5b80e5b7592c1d90aa895bc967d4cfe8bfda44 /gnu/packages/ocaml.scm
parent90907a22bcfc47c5027ecb830b34f226228f1f4e (diff)
downloadguix-f5a8491b6983087fe85002a7b6435119332892c2.tar.gz
gnu: hevea: Update to 2.28.
* gnu/packages/ocaml.scm (hevea): Update to 2.28.
  [arguments]: Add 'patch-/bin/sh phase.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d71ae55e7b..1311b1bc37 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -286,14 +286,14 @@ concrete syntax of the language (Quotations, Syntax Extensions).")
 (define-public hevea
   (package
     (name "hevea")
-    (version "2.23")
+    (version "2.28")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://hevea.inria.fr/old/"
                                   name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1f9pj48518ixhjxbviv2zx27v4anp92zgg3x704g1s5cki2w33nv"))))
+                "14fns13wlnpiv9i05841kvi3cq4b9v2sw5x3ff6ziws28q701qnd"))))
     (build-system gnu-build-system)
     (inputs
      `(("ocaml" ,ocaml)))
@@ -301,7 +301,12 @@ concrete syntax of the language (Quotations, Syntax Extensions).")
      `(#:tests? #f  ; no test suite
        #:make-flags (list (string-append "PREFIX=" %output))
        #:phases (modify-phases %standard-phases
-                  (delete 'configure))))
+                  (delete 'configure)
+                  (add-before 'build 'patch-/bin/sh
+                    (lambda _
+                      (substitute* "_tags"
+                        (("/bin/sh") (which "sh")))
+                      #t)))))
     (home-page "http://hevea.inria.fr/")
     (synopsis "LaTeX to HTML translator")
     (description