summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-03-24 14:46:50 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-03-24 15:27:49 +0100
commitd7d41026645fddf8876504cd1f053a3a396ff13d (patch)
tree4326d1b24508c79d7cc1245b78d78786de5aa8bb /gnu/packages/ocaml.scm
parent24c4b012ee9789e2e767da826d9dccf71bbad3b5 (diff)
downloadguix-d7d41026645fddf8876504cd1f053a3a396ff13d.tar.gz
gnu: ocaml-react: Update to 1.2.1.
* gnu/packages/ocaml.scm (ocaml-react): Update to 1.2.1.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a6889c642e..5b3e996db2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1795,21 +1795,22 @@ simple (yet expressive) query language to select the tests to run.")
 (define-public ocaml-react
   (package
     (name "ocaml-react")
-    (version "1.2.0")
+    (version "1.2.1")
     (source
       (origin
         (method url-fetch)
         (uri (string-append "http://erratique.ch/software/react/releases/react-"
                             version ".tbz"))
         (sha256 (base32
-                  "0knhgbngphv5sp1yskfd97crf169qhpc0igr6w7vqw0q36lswyl8"))))
+                  "1aj8w79gdd9xnrbz7s5p8glcb4pmimi8jp9f439dqnf6ih3mqb3v"))))
     (build-system ocaml-build-system)
     (native-inputs
      `(("ocamlbuild" ,ocamlbuild)
-       ("opam" ,opam)))
+       ("opam" ,opam)
+       ("ocaml-topkg" ,ocaml-topkg)))
     (arguments
      `(#:tests? #f
-       #:build-flags (list "native=true" "native-dynlink=true")
+       #:build-flags (list "build")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))))