summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:01:03 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:40 +0100
commitb42afab2e2aaa6415700a934c20d7dd0fb6f7834 (patch)
treeae3cecdea19b3e4c1b17c7c0c492b70a9e6352d0 /gnu/packages/ocaml.scm
parentdb67f56901fcb5b365281dd726ed9c06c993e054 (diff)
downloadguix-b42afab2e2aaa6415700a934c20d7dd0fb6f7834.tar.gz
gnu: Add ocaml-ppx-bench.
* gnu/packages/ocaml.scm (ocaml-ppx-bench): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 78f26b4f6d..70ff74fe81 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5462,3 +5462,29 @@ hash functions from type exrpessions and definitions.")
 for the list of all values of a type (for a type which only has finitely
 many values).")
     (license license:asl2.0)))
+
+(define-public ocaml-ppx-bench
+  (package
+    (name "ocaml-ppx-bench")
+    (version "0.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+                                  (version-major+minor version)
+                                  "/files/ppx_bench-v" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ys4pblbcjbk9dn073rqiwm7r6rc7fah03j7riklkwnb5n44andl"))))
+    (build-system dune-build-system)
+    (arguments
+     ;; No tests
+     `(#:tests? #f))
+    (propagated-inputs
+      `(("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
+        ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+        ("ocaml-ppxlib" ,ocaml-ppxlib)))
+    (properties `((upstream-name . "ppx_bench")))
+    (home-page "https://github.com/janestreet/ppx_bench")
+    (synopsis "Syntax extension for writing in-line benchmarks in ocaml code")
+    (description "Syntax extension for writing in-line benchmarks in ocaml code.")
+    (license license:asl2.0)))