summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-09-03 19:42:21 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-09-03 23:31:31 +0200
commitf082c78c98d8fee4acd89dd40081c7fd7a081b74 (patch)
treedac049af069f069604d93beea038cfc7c48197ae /gnu/packages/ocaml.scm
parent242e9f0d2cb6c11a2e4f2001ba71beb7e6a68810 (diff)
downloadguix-f082c78c98d8fee4acd89dd40081c7fd7a081b74.tar.gz
gnu: ocaml-cppo: Update to 1.6.6.
* gnu/packages/ocaml.scm (ocaml-cppo): Update to 1.6.6.
[source]: Use git-fetch.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3bc28164fc..af10411f88 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2466,15 +2466,16 @@ from the oasis build log
 (define-public ocaml-cppo
   (package
     (name "ocaml-cppo")
-    (version "1.6.5")
+    (version "1.6.6")
     (source
       (origin
-        (method url-fetch)
-        (uri (string-append "https://github.com/mjambon/cppo/archive/v" version
-                            ".tar.gz"))
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/mjambon/cppo")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
         (sha256 (base32
-                  "1dkm3d5h6h56y937gcdk2wixlpzl59vv5pmiafglr89p20kf7gqf"))
-        (file-name (string-append name "-" version ".tar.gz"))))
+                  "1smcc0l6fh2n0y6bp96c69j5nw755jja99w0b206wx3yb2m4w2hs"))))
     (build-system dune-build-system)
     (arguments
      `(#:tests? #f