summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorIvan Gankevich <i.gankevich@spbu.ru>2021-07-07 10:13:41 +0300
committerJulien Lepiller <julien@lepiller.eu>2021-07-10 15:02:12 +0200
commitc21ccbf14e211bf3417c04f5add733a1e49b44fa (patch)
tree43069e6406fea7af6a09be323dab9d31d436626d /gnu/packages/ocaml.scm
parentf7f6cbb6b68fd88543097bb69b992a86043499ce (diff)
downloadguix-c21ccbf14e211bf3417c04f5add733a1e49b44fa.tar.gz
gnu: Add ocaml-bibtex2html.
* gnu/packages/ocaml.scm (ocaml-bibtex2html): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d5fda3d334..727c7a08c8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7176,3 +7176,33 @@ libraries.")
 It makes it possible to run pure OCaml programs in JavaScript environment like
 browsers and Node.js.")
     (license license:lgpl2.1+)))
+
+(define-public ocaml-bibtex2html
+  (package
+    (name "ocaml-bibtex2html")
+    (version "1.99")
+    (source
+      (origin
+        (method url-fetch)
+        (uri "https://www.lri.fr/~filliatr/ftp/bibtex2html/bibtex2html-1.99.tar.gz")
+        (sha256 (base32 "07gzrs4lfrkvbn48cgn2gn6c7cx3jsanakkrb2irj0gmjzfxl96j"))))
+    (build-system ocaml-build-system)
+    (arguments
+      `(#:phases
+        (modify-phases %standard-phases
+          (add-after 'unpack 'patch-/bin/sh
+            (lambda _
+              (substitute* "configure" (("/bin/sh") (which "bash")))
+              (setenv "HOME" (getcwd)) ;; mktexfmt needs writable home directory
+              #t)))))
+    (native-inputs
+     `(("which" ,which)
+       ("texlive" ,(texlive-union (list texlive-fonts-ec texlive-preprint
+                                        texlive-latex-hyperref texlive-bibtex)))))
+    (propagated-inputs
+     `(("hevea" ,hevea)))
+    (home-page "https://www.lri.fr/~filliatr/bibtex2html/")
+    (synopsis "BibTeX to HTML translator")
+    (description "This package allows you to produce, from a set of
+bibliography files in BibTeX format, a bibliography in HTML format.")
+    (license license:gpl2)))