summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-22 18:36:58 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-24 02:13:50 +0100
commitec861f696438303237a923639aefac38b79be84f (patch)
treebfc58f33fc78c48d79e0ba3cab039aaeea791f64 /gnu/packages/ocaml.scm
parentddea3012367961204726c0f08fd6c95111f58c4d (diff)
downloadguix-ec861f696438303237a923639aefac38b79be84f.tar.gz
gnu: Add ocaml-mew-vi.
* gnu/packages/ocaml.scm (ocaml-mew-vi): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 427ee2c682..82670fec7f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7483,6 +7483,32 @@ OCaml.")
 modal editing engine generator.")
     (license license:expat)))
 
+(define-public ocaml-mew-vi
+  (package
+    (name "ocaml-mew-vi")
+    (version "0.5.0")
+    (home-page "https://github.com/kandu/mew_vi")
+    (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+        (sha256
+          (base32 "0lihbf822k5zasl60w5mhwmdkljlq49c9saayrws7g4qc1j353r8"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+      `(("ocaml-mew" ,ocaml-mew)
+        ("ocaml-react" ,ocaml-react)))
+    (native-inputs
+     `(("ocaml-ppx-expect" ,ocaml-ppx-expect)))
+    (properties `((upstream-name . "mew_vi")))
+    (synopsis "Modal editing VI-like editing engine generator")
+    (description "This module provides a vi-like modal editing engine
+generator.")
+    (license license:expat)))
+
 (define-public ocaml-syntax-shims
   (package
     (name "ocaml-syntax-shims")