summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-19 17:50:40 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-20 02:15:02 +0200
commit620b4e8ad3b8a6c3a770a5a3ab69b546d7570df7 (patch)
tree83b2587175a069baa418b5709fa0da2d591f8bfc /gnu/packages/ocaml.scm
parentfe6fd923a8b5a8307ae47c1f218dc9b9b41a722d (diff)
downloadguix-620b4e8ad3b8a6c3a770a5a3ab69b546d7570df7.tar.gz
gnu: Add ocaml-mparser-re.
* gnu/packages/ocaml.scm (ocaml-mparser-re): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0117f6dca2..f795f8d918 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6827,6 +6827,21 @@ the FParsec library for FSharp by Stephan Tolksdorf.")
     ;; With static linking exception.
     (license license:lgpl2.1+)))
 
+(define-public ocaml-mparser-re
+  (package
+    (inherit ocaml-mparser)
+    (name "ocaml-mparser-re")
+    (arguments
+     ;; No tests.
+     '(#:package "mparser-re"
+       #:tests? #f))
+    (propagated-inputs
+     `(("ocaml-mparser" ,ocaml-mparser)
+       ("ocaml-re" ,ocaml-re)))
+    (synopsis "MParser plugin for RE-based regular expressions")
+    (description "This package provides RE-based regular expressions
+support for Mparser.")))
+
 (define-public lablgtk3
   (package
     (name "lablgtk")