summary refs log tree commit diff
path: root/gnu/packages/ocr.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2019-08-06 23:52:41 +0800
committerAlex Vong <alexvong1995@gmail.com>2019-09-17 13:29:03 +0800
commit16dd1fd044b3d47939707e0a863cb461c7455d25 (patch)
tree08b1d1970fd6aa8245e552e89772a8166648e567 /gnu/packages/ocr.scm
parent9a94ccec4c14dab78326b2b1c449cd4ccd987bcb (diff)
downloadguix-16dd1fd044b3d47939707e0a863cb461c7455d25.tar.gz
gnu: Add python2-zinnia.
* gnu/packages/ocr.scm (python2-zinnia): New variable.
Diffstat (limited to 'gnu/packages/ocr.scm')
-rw-r--r--gnu/packages/ocr.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index 14ea7e443b..1266e7e419 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -25,7 +25,9 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages image))
 
 (define-public ocrad
@@ -131,3 +133,21 @@ that allows us to create any hand-written recognition systems with low-cost.")
                       "file://zinnia/aclocal.m4")
                      license:x11 ; 'install-sh'
                      license:public-domain))))) ; 'install-sh'
+
+;;; python 2 bindings, license under the same terms as zinnia
+(define-public python2-zinnia
+  (package
+    (inherit zinnia)
+    (name "python2-zinnia")
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2 ; CObject API is used, it was removed in Python 3.2
+       #:tests? #f ; avoid circular dependency on tegaki-zinnia-japanese
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _
+             (chdir "zinnia/python")
+             #t)))))
+    (inputs
+     `(("zinnia" ,zinnia)))))