summary refs log tree commit diff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-15 21:18:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-15 21:18:01 +0200
commit4b70b776e5b397fc5c15f628561a332e29d1584e (patch)
treeb2c7ac27644a63de13a2279fb98ae0cf7c02217b /gnu/packages/onc-rpc.scm
parente6e09dc9c53df38e48be331a5f930ef6d52454f4 (diff)
downloadguix-4b70b776e5b397fc5c15f628561a332e29d1584e.tar.gz
gnu: libnsl: Fix build with gettext 0.20.
* gnu/packages/onc-rpc.scm (libnsl)[arguments]: New field.
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index d3149a4629..553553e2c2 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -137,6 +137,14 @@ from the protocol files.")
                (base32
                 "1chzqhcgh0yia9js8mh92cmhyka7rh32ql6b3mgdk26n94dqzs8b"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'bootstrap 'gettextize
+                    (lambda _
+                      ;; Regenerate the bundled Makefile.in.in to avoid a
+                      ;; "gettext infrastructure mismatch" because the
+                      ;; existing version was generated by an older gettext.
+                      (invoke "gettextize" "-f"))))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)