summary refs log tree commit diff
path: root/gnu/packages/openbox.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/openbox.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running:

  ./pre-inst-env guix style --input-simplification=safe

and manually undoing changes on a dozen of packages to reduce
rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/openbox.scm')
-rw-r--r--gnu/packages/openbox.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/openbox.scm b/gnu/packages/openbox.scm
index fb590ce97f..873592c19e 100644
--- a/gnu/packages/openbox.scm
+++ b/gnu/packages/openbox.scm
@@ -50,17 +50,17 @@
     (build-system gnu-build-system)
     (native-inputs (list pkg-config))
     (propagated-inputs (list python2-pyxdg))
-    (inputs `(("imlib2" ,imlib2)
-              ("libxml2" ,libxml2)
-              ("librsvg" ,(librsvg-for-system))
-              ("libsm" ,libsm)
-              ("libxcursor" ,libxcursor)
-              ("libxinerama" ,libxinerama)
-              ("libxml2" ,libxml2)
-              ("libxrandr" ,libxrandr)
-              ("libxft" ,libxft)
-              ("pango" ,pango)
-              ("python-2" ,python-2)))
+    (inputs (list imlib2
+                  libxml2
+                  (librsvg-for-system)
+                  libsm
+                  libxcursor
+                  libxinerama
+                  libxml2
+                  libxrandr
+                  libxft
+                  pango
+                  python-2))
     (synopsis "Box style window manager")
     (description
      "Openbox is a highly configurable, next generation window manager with