summary refs log tree commit diff
path: root/gnu/packages/opencog.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/opencog.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
Diffstat (limited to 'gnu/packages/opencog.scm')
-rw-r--r--gnu/packages/opencog.scm31
1 files changed, 10 insertions, 21 deletions
diff --git a/gnu/packages/opencog.scm b/gnu/packages/opencog.scm
index cca0b37ead..998d9b47ae 100644
--- a/gnu/packages/opencog.scm
+++ b/gnu/packages/opencog.scm
@@ -54,7 +54,7 @@
       (arguments
        `(#:test-target "tests"))
       (inputs
-       `(("boost" ,boost)))
+       (list boost))
       (native-inputs
        `(("cxxtest" ,cxxtest)
          ("python" ,python-minimal)
@@ -93,11 +93,7 @@ utilities use for typical programming tasks in multiple OpenCog projects.")
                               (assoc-ref %outputs "out")
                               "/share/guile/site/2.2/"))))
       (inputs
-       `(("boost" ,boost)
-         ("cogutil" ,cogutil)
-         ("gmp" ,gmp)
-         ("guile" ,guile-2.2)
-         ("postgresql" ,postgresql)))
+       (list boost cogutil gmp guile-2.2 postgresql))
       (native-inputs
        `(("cxxtest" ,cxxtest)
          ("python" ,python-minimal)
@@ -139,11 +135,7 @@ features not otherwise available.")
                               (assoc-ref %outputs "out")
                               "/share/guile/site/2.2/"))))
       (inputs
-       `(("atomspace" ,atomspace)
-         ("boost" ,boost)
-         ("cogutil" ,cogutil)
-         ("gmp" ,gmp)
-         ("guile" ,guile-2.2)))
+       (list atomspace boost cogutil gmp guile-2.2))
       (native-inputs
        `(("cxxtest" ,cxxtest)
          ("python" ,python-minimal)
@@ -182,12 +174,12 @@ OpenCog framework.")
                          (assoc-ref %outputs "out")
                          "/share/guile/site/2.2/"))))
       (inputs
-       `(("atomspace" ,atomspace)
-         ("boost" ,boost)
-         ("cogserver" ,cogserver)
-         ("cogutil" ,cogutil)
-         ("gmp" ,gmp)
-         ("guile" ,guile-2.2)))
+       (list atomspace
+             boost
+             cogserver
+             cogutil
+             gmp
+             guile-2.2))
       (native-inputs
        `(("cxxtest" ,cxxtest)
          ("python" ,python-minimal)
@@ -288,10 +280,7 @@ combination.")
                                          "/share/guile/site/2.2/opencog"))))
                #t)))))
       (inputs
-       `(("atomspace" ,atomspace)
-         ("cogutil" ,cogutil)
-         ("gmp" ,gmp)
-         ("guile" ,guile-2.2)))
+       (list atomspace cogutil gmp guile-2.2))
       (native-inputs
        `(("cxxtest" ,cxxtest)
          ("python" ,python-minimal)