summary refs log tree commit diff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-30 14:56:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-30 15:32:35 +0200
commit6cd6b0abe74d74e4aea81ffdf2c46858a0b20d93 (patch)
treedc36c6715cc1ba11f5811f19fec1ebdfd7b869bf /gnu/packages/openldap.scm
parent2bec19199e6a42a6d0419a59230e5688e4b7eca0 (diff)
downloadguix-6cd6b0abe74d74e4aea81ffdf2c46858a0b20d93.tar.gz
gnu: 389-ds-base: Restore definition of pythondir.
* gnu/packages/openldap.scm (389-ds-base)[arguments]: Import python-version
from (guix build python-build-system); define pythondir before using it in
fix-install-location-of-python-tools.
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 861568c018..5a5602805f 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -229,7 +229,7 @@ servers from Python programs.")
      `(#:modules ((srfi srfi-1)
                   (guix build gnu-build-system)
                   ((guix build python-build-system)
-                   #:select (add-installed-pythonpath))
+                   #:select (add-installed-pythonpath python-version))
                   (guix build utils))
        #:imported-modules ((guix build python-build-system)
                            ,@%gnu-build-system-modules)
@@ -282,7 +282,11 @@ servers from Python programs.")
                   "etc_dirsrv_path = '/etc/dirsrv/'\n")))))
          (add-after 'unpack 'fix-install-location-of-python-tools
            (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
+             (let* ((out (assoc-ref outputs "out"))
+                    (pythondir (string-append
+                                out "/lib/python"
+                                (python-version (assoc-ref inputs "python"))
+                                "/site-packages/")))
                ;; Install directory must be on PYTHONPATH.
                (add-installed-pythonpath inputs outputs)
                ;; Install directory must exist.