summary refs log tree commit diff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-21 20:47:50 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:39:01 +0200
commitead37cb68557f40823fed8f932ddf051261e2438 (patch)
treeb6c365d44d6e6a763ec94889de06a54165f28222 /gnu/packages/openstack.scm
parent6937cea1996a21321b6cc041c37e4c0381c9b6a0 (diff)
downloadguix-ead37cb68557f40823fed8f932ddf051261e2438.tar.gz
gnu: python-swiftclient: Update to 4.0.1.
* gnu/packages/openstack.scm (python-swiftclient): Update to 4.0.1.
  [arguments]<phases>{relax-requirements}: New phase.
  [arguments]<phases>{check}: New phase.
  [propagated-inputs]: Remove python-six.
  [native-inputs]: Remove python-pbr, python-sphinx, python-coverage,
  python-discover, python-hacking, python-mock, python-oslosphinx,
  python-testrepository, and python-testtools; add python-keystoneauth1,
  python-openstacksdk, and python-stestr.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 844f535286..dd13404c87 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -917,29 +917,31 @@ LDAP.")
 (define-public python-swiftclient
   (package
     (name "python-swiftclient")
-    (version "2.6.0")
+    (version "4.0.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "python-swiftclient" version))
         (sha256
          (base32
-          "1j33l4z9vqh0scfncl4fxg01zr1hgqxhhai6gvcih1gccqm4nd7p"))))
+          "1zwb4zcln454fzcnbwqhyzxb68wrsr1i2vvvrn5c7yy5k4vcfs1v"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'relax-requirements
+                    (lambda _
+                      (delete-file "test-requirements.txt")))
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "stestr" "run")))))))
     (native-inputs
-     (list python-pbr
-           python-sphinx
-           ;; The folloing packages are needed for the tests.
-           python-coverage
-           python-discover
-           python-hacking
-           python-mock
-           python-oslosphinx
-           python-keystoneclient
-           python-testrepository
-           python-testtools))
+     (list python-keystoneclient
+           python-keystoneauth1
+           python-openstacksdk
+           python-stestr))
     (propagated-inputs
-     (list python-requests python-six))
+     (list python-requests))
     (home-page "https://www.openstack.org/")
     (synopsis "OpenStack Object Storage API Client Library")
     (description