summary refs log tree commit diff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-21 15:41:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-21 17:24:31 +0200
commit3bbfc451edcb9af438eb8e205d3016203e0ef8e4 (patch)
tree929584b299c324649e2619795741dd3bed8fe978 /gnu/packages/openstack.scm
parentf70785a4c0e12eb2db0ee8e66a41d3a9952a1f63 (diff)
downloadguix-3bbfc451edcb9af438eb8e205d3016203e0ef8e4.tar.gz
gnu: python-sphinx: Update to 1.7.7.
* gnu/packages/openstack.scm (python-mox3, python-openstackdocstheme,
  python-stevedore, python-oslo.config)[native-inputs]: Change
PYTHON-SPHINX-1.6 to PYTHON-SPHINX.
* gnu/packages/python.scm (python-sphinx): Update to 1.7.7.
[arguments]: Incorporate changes from the 1.6 variant.  Disable two tests.
[propagated-inputs]: Add PYTHON-PACKAGING and PYTHON-SPHINXCONTRIB-WEBSUPPORT.
[native-inputs]: Add IMAGEMAGICK and PYTHON-PYTEST.
(python2-sphinx)[propagated-inputs]: Add PYTHON2-TYPING.
(python-sphinx-1.6, python2-sphinx-1.6, python-sphinx-1.5.3): Remove variables.
(python-matplotlib-documentation)[native-inputs]: Change from
PYTHON-SPHINX-1.6 to PYTHON-SPHINX.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 64e05c4b0e..c07f011c9d 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -182,7 +182,7 @@ guidelines}.")
        ("python-pbr" ,python-pbr)))
     (native-inputs
       `(("python-openstackdocstheme" ,python-openstackdocstheme)
-        ("python-sphinx" ,python-sphinx-1.6)
+        ("python-sphinx" ,python-sphinx)
         ("python-subunit" ,python-subunit)
         ("python-testrepository" ,python-testrepository)
         ("python-testtools" ,python-testtools)))
@@ -216,7 +216,7 @@ with mox as possible, but small enhancements have been made.")
      `(("python-dulwich" ,python-dulwich)
        ("python-pbr" ,python-pbr)))
     (native-inputs
-     `(("python-sphinx" ,python-sphinx-1.6)))
+     `(("python-sphinx" ,python-sphinx)))
     (home-page "https://docs.openstack.org/openstackdocstheme/latest/")
     (synopsis "OpenStack Docs Theme")
     (description
@@ -313,7 +313,7 @@ to docs.openstack.org and developer.openstack.org.")
        ("python-six" ,python-six)))
     (native-inputs
      `(("python-mock" ,python-mock)
-       ("python-sphinx" ,python-sphinx-1.6)
+       ("python-sphinx" ,python-sphinx)
        ("python-testrepository" ,python-testrepository)))
     (home-page "https://github.com/dreamhost/stevedore")
     (synopsis "Manage dynamic plugins for Python applications")
@@ -405,7 +405,7 @@ common features used in Tempest.")
        ("python-openstackdocstheme" ,python-openstackdocstheme)
        ("python-oslotest" ,python-oslotest)
        ("python-reno" ,python-reno)
-       ("python-sphinx" ,python-sphinx-1.6)
+       ("python-sphinx" ,python-sphinx)
        ("python-testrepository" ,python-testrepository)
        ("python-testscenarios" ,python-testscenarios)
        ("python-testtools" ,python-testtools)))