summary refs log tree commit diff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-02-18 18:12:34 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-02-18 18:12:34 +0100
commit27693b1e34347c4e2e4d12283c8c825ec6332716 (patch)
treecfb9c9c33256738b3697c2904b4b417f84c4c0e6 /gnu/packages/openstack.scm
parent9c4810b47cdf2aeccfbb99a6af427c6c2777c46e (diff)
downloadguix-27693b1e34347c4e2e4d12283c8c825ec6332716.tar.gz
gnu: python-oslosphinx: Re-enable tests.
* gnu/packages/openstack.scm (python-oslosphinx): Re-enable tests.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index fe0dd11eb3..381480b786 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -604,9 +604,15 @@ and building documentation from them.")
         (base32
          "09mxqyabi68f3s3arvdhlhq0mn38vf74jbsfcg84151hcj6czhnl"))))
     (build-system python-build-system)
-    ;; FIXME: Incompatible sphinx version.
     (arguments
-     '(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             ;; Note: Upstream tests would have also built the release notes.
+             ;; That only would work if we were in a git checkout.
+             ;; Therefore, we don't do it here.
+             (zero? (system* "python" "setup.py" "build_sphinx")))))))
     (propagated-inputs
       `(("python-requests" ,python-requests)))
     (native-inputs