summary refs log tree commit diff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-28 01:18:54 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 13:59:01 +0100
commit1cccdca2310adbc0932ae2fbf0a7fe064851a5d5 (patch)
tree6729e9a0c95f17986e01f5f77833724e9c8a348c /gnu/packages/openstack.scm
parent3e3302acc51aca4415b394b067e69249d3f11e06 (diff)
downloadguix-1cccdca2310adbc0932ae2fbf0a7fe064851a5d5.tar.gz
gnu: python-stevedore: Update to 1.28.0.
* gnu/packages/openstack.scm (python-stevedore): Update to 1.28.0.
[propagated-inputs]: Add PYTHON-PBR.
[native-inputs]: Remove PYTHON-PBR, PYTHON-DISCOVER, PYTHON-DOCUTILS,
PYTHON-OSLOSPHINX and PYTHON-OSLOTEST.  Replace PYTHON-SPHINX with
PYTHON-SPHINX-1.6.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 461006fc7b..be858e17c3 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -283,27 +283,22 @@ to docs.openstack.org and developer.openstack.org.")
 (define-public python-stevedore
   (package
     (name "python-stevedore")
-    (version "1.12.0")
+    (version "1.28.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "stevedore" version))
        (sha256
-         (base32
-          "0999zvawaapzg6givjhn7vjscdwblcs73wf28wq1wb4g5mbb5phv"))))
+        (base32
+         "02ynfgwma84g59834dmvzr39mcppy5s229zf1w23c0qngf753izi"))))
     (build-system python-build-system)
     (propagated-inputs
-      `(("python-six" ,python-six)))
+     `(("python-pbr" ,python-pbr)
+       ("python-six" ,python-six)))
     (native-inputs
-      `(("python-pbr" ,python-pbr)
-        ;; Tests
-        ("python-discover" ,python-discover)
-        ("python-docutils" ,python-docutils)
-        ("python-mock" ,python-mock)
-        ("python-oslosphinx" ,python-oslosphinx)
-        ("python-oslotest" ,python-oslotest)
-        ("python-sphinx" ,python-sphinx)
-        ("python-testrepository" ,python-testrepository)))
+     `(("python-mock" ,python-mock)
+       ("python-sphinx" ,python-sphinx-1.6)
+       ("python-testrepository" ,python-testrepository)))
     (home-page "https://github.com/dreamhost/stevedore")
     (synopsis "Manage dynamic plugins for Python applications")
     (description