summary refs log tree commit diff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-24 21:42:04 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-24 21:44:56 +0100
commitfc68f611929df574c040e15f6653cee63401f8e2 (patch)
tree1ece6d5456c63eb7ad77c2a853b52660a7e14faa /gnu/packages/package-management.scm
parent9d01749feaa1586b1caf449712116e7518bb2303 (diff)
downloadguix-fc68f611929df574c040e15f6653cee63401f8e2.tar.gz
gnu: guix-jupyter: Update to 0.2.0.
* gnu/packages/package-management.scm (guix-jupyter): Update to 0.2.0.
[source]: Remove 'modules' and 'snippet'.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm21
1 files changed, 2 insertions, 19 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 2f3f575d3f..7bfe21baf4 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1140,7 +1140,7 @@ outputs of those builds.")
 (define-public guix-jupyter
   (package
     (name "guix-jupyter")
-    (version "0.1.0")
+    (version "0.2.0")
     (home-page "https://gitlab.inria.fr/guix-hpc/guix-kernel")
     (source (origin
               (method git-fetch)
@@ -1148,24 +1148,7 @@ outputs of those builds.")
                                   (commit (string-append "v" version))))
               (sha256
                (base32
-                "01z7jjkc7r7lj6637rcgpz40v8xqqyfp6871h94yvcnwm7zy9h1n"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  ;; Allow builds with Guile 3.0.
-                  (substitute* "configure.ac"
-                    (("^GUILE_PKG.*")
-                     "GUILE_PKG([3.0 2.2])\n"))
-
-                  ;; Avoid name clash and build failure now that
-                  ;; 'define-json-mapping' is also provided by Guile-JSON, as
-                  ;; of version 4.3.
-                  (substitute* (find-files "." "\\.scm$")
-                    (("define-json-mapping")
-                     "define-json-mapping*")
-                    (("<=>")
-                     "<->"))
-                  #t))
+                "1bjddkj1px1xzm3gia87sclphwsnr4vb92vrfi8gh5dx0z73dmc5"))
               (file-name (string-append "guix-jupyter-" version "-checkout"))))
     (build-system gnu-build-system)
     (arguments