summary refs log tree commit diff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-05 13:58:36 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-05 14:11:54 +0100
commite8e2e18b84eb8842a59be9bf7d49bb672260ae3a (patch)
treef5b237e29d64ad6a2962af0251a39929e4a4d09c /gnu/packages/package-management.scm
parenta2ab82db9ab5d6db86762924d3016aed7c26c315 (diff)
downloadguix-e8e2e18b84eb8842a59be9bf7d49bb672260ae3a.tar.gz
gnu: Read 'C_INCLUDE_PATH' instead of 'CPATH'.
This is a followup to 009b53fd.

* gnu/packages/cmake.scm (cmake)[arguments]: Use (getenv
"C_INCLUDE_PATH") instead of (getenv "CPATH").
* gnu/packages/package-management.scm (rpm)[arguments]: Likewise.
* gnu/packages/video.scm (avidemux)[arguments]: Likewise.
* gnu/packages/webkit.scm (webkitgtk)[arguments]: Likewise.
* gnu/packages/cross-base.scm (cross-gcc-arguments): Likewise, and unset
'C_INCLUDE_PATH' and 'CPLUS_INCLUDE_PATH'.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 917464543c..b8d0c9c2ac 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -340,7 +340,7 @@ symlinks to the files in a common directory such as /usr/local.")
                       (let ((nspr (assoc-ref inputs "nspr"))
                             (nss  (assoc-ref inputs "nss")))
                         (setenv "CPATH"
-                                (string-append (getenv "CPATH") ":"
+                                (string-append (getenv "C_INCLUDE_PATH") ":"
                                                nspr "/include/nspr:"
                                                nss "/include/nss"))
                         (setenv "LIBRARY_PATH"