summary refs log tree commit diff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-13 19:31:24 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-13 22:33:37 +0200
commit932e7204afbe6d56b8319f7c298ea43e12004a95 (patch)
tree767b5e115692ca6b06d700ff0b5371c8c6dfacdc /gnu/packages/package-management.scm
parent02c2cf43ce53718f02376c438b87504a7a2e1c0a (diff)
downloadguix-932e7204afbe6d56b8319f7c298ea43e12004a95.tar.gz
gnu: guix: Wrap 'guix' so GUILE_LOAD_PATH includes the dependencies.
* gnu/packages/package-management.scm (guix-0.8.2)[arguments]: Add
  'wrap-program' phase.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 33dce5c809..7f6ec56151 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -99,7 +99,22 @@
                      (copy "x86_64")
                      (copy "mips64el")
                      (copy "armhf")
-                     #t)))))
+                     #t))
+                  (add-after
+                   'install 'wrap-program
+                   (lambda* (#:key inputs outputs #:allow-other-keys)
+                     ;; Make sure the 'guix' command finds GnuTLS and
+                     ;; Guile-JSON automatically.
+                     (let* ((out    (assoc-ref outputs "out"))
+                            (json   (assoc-ref inputs "guile-json"))
+                            (gnutls (assoc-ref inputs "gnutls"))
+                            (path   (string-append
+                                     json "/share/guile/site/2.0:"
+                                     gnutls "/share/guile/site/2.0")))
+                       (wrap-program (string-append out "/bin/guix")
+                         `("GUILE_LOAD_PATH" ":" prefix (,path))
+                         `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,path)))
+                       #t))))))
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("emacs" ,emacs-no-x)))      ;for guix.el
     (inputs