summary refs log tree commit diff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 21:18:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:14 +0100
commita1785cfb6d198b960dcf19866203b5e2ab808116 (patch)
tree64ce892ce18661de86114d3edc3cb74494bc35db /gnu/packages/package-management.scm
parent051ae68b7a5081afa1e0cc6dfdee245220b36911 (diff)
downloadguix-a1785cfb6d198b960dcf19866203b5e2ab808116.tar.gz
gnu: gcab: Update to 1.2.
* gnu/packages/package-management.scm (gcab): Update to 1.2.
[source]: Remove snippet.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c3b195a64f..07665e3579 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
 ;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
@@ -836,23 +836,14 @@ on top of GNU Guix.")
 (define-public gcab
   (package
     (name "gcab")
-    (version "1.1")
+    (version "1.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
                                   version "/" name "-" version ".tar.xz"))
               (sha256
                (base32
-                "0l19sr6pg0cfcddmi5n79d08mjjbhn427ip5jlsy9zddq9r24aqr"))
-              ;; gcab 1.1 has a hard dependency on git — even when building
-              ;; from a tarball.  Remove it early so ‘guix environment gcab’
-              ;; can actually build what ‘guix build --source gcab’ returns.
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (substitute* "meson.build"
-                    (("git_version = .*$") "git_version = []\n"))
-                  #t))))
+                "038h5kk41si2hc9d9169rrlvp8xgsxq27kri7hv2vr39gvz9cbas"))))
     (build-system meson-build-system)
     (native-inputs
      `(("glib:bin" ,glib "bin")         ; for glib-mkenums