summary refs log tree commit diff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-27 22:38:25 +0100
committerLudovic Courtès <ludo@gnu.org>2021-02-04 09:23:39 +0100
commit8ecc265c5c6519986758567682726647850d5d03 (patch)
tree0dca5936f04e7f047cab71fceeeec5a1a9cf6271 /gnu/packages/package-management.scm
parent55daad123e896c0e83361496cf49625289ee3571 (diff)
downloadguix-8ecc265c5c6519986758567682726647850d5d03.tar.gz
gnu: guix: Pass the '--with-channel-commit' configure flag.
* gnu/packages/package-management.scm (guix)[arguments]: Add
'--with-channel-commit' to #:configure-flags.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 8cfe5f3ef2..7b853e781e 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -154,6 +154,13 @@
       (build-system gnu-build-system)
       (arguments
        `(#:configure-flags (list
+
+                            ;; Provide channel metadata for 'guix describe'.
+                            ;; Don't pass '--with-channel-url' and
+                            ;; '--with-channel-introduction' and instead use
+                            ;; the defaults.
+                            ,(string-append "--with-channel-commit=" commit)
+
                             "--localstatedir=/var"
                             "--sysconfdir=/etc"
                             (string-append "--with-bash-completion-dir="