summary refs log tree commit diff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-01 00:40:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-01 00:49:16 +0100
commit988f53e1be6e63826f147e48ed1f51d2b2dbe728 (patch)
tree79ca24787a1d05c2fc93c8e9bfcdd174672ad5a7 /gnu/packages/password-utils.scm
parenta50d6099dda3453d72b25faec435d00adf14c553 (diff)
downloadguix-988f53e1be6e63826f147e48ed1f51d2b2dbe728.tar.gz
gnu: yapet: Update to 2.3.
* gnu/packages/password-utils.scm (yapet): Update to 2.3.
[inputs]: Add argon2.
[native-inputs]: Add cppunit.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index e1555cc194..dd24808a7e 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -294,21 +294,22 @@ applications, there is xclip integration." )
 (define-public yapet
   (package
     (name "yapet")
-    (version "1.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "http://www.guengel.ch/myapps/yapet/downloads/yapet-"
-                                  version
-                                  ".tar.bz2"))
-              (sha256
-               (base32
-                "1lq46mpxdsbl6qw4cj58hp9q7jckmyvbsi08p5zr77rjgqadxyyy"))))
+    (version "2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://yapet.guengel.ch/downloads/yapet-"
+                           version ".tar.xz"))
+       (sha256
+        (base32 "1fl4s7v1psl52ndd6i7716i9f493aj8ipl6lgmraadnn5h26l3pm"))))
     (build-system gnu-build-system)
     (inputs
-     `(("ncurses" ,ncurses)
+     `(("argon2" ,argon2)
+       ("ncurses" ,ncurses)
        ("openssl" ,openssl)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("cppunit" ,cppunit)
+       ("pkg-config" ,pkg-config)))
     (synopsis "Yet Another Password Encryption Tool")
     (description "YAPET is a text based password manager using the Blowfish
 encryption algorithm.  Because of its small footprint and very few library