summary refs log tree commit diff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-22 13:04:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-22 14:17:32 +0200
commitfe109349d0cfb8d6c2cc8509ed6c4da86da0ca26 (patch)
tree6854e54f2d61ab7b09eed50ee0145e15993f4b80 /gnu/packages/password-utils.scm
parentc600cf2a72fef7994f85a1e5c3f986a79a5024cc (diff)
downloadguix-fe109349d0cfb8d6c2cc8509ed6c4da86da0ca26.tar.gz
gnu: argon2: Update to 20190702.
* gnu/packages/password-utils.scm (argon2): Update to 20190702.
[arguments]: Adjust make-flags. Remove 'patch-Makefile phase.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm29
1 files changed, 8 insertions, 21 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index af09f7b462..eed0989452 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -703,7 +703,7 @@ using password-store through rofi interface:
 (define-public argon2
   (package
     (name "argon2")
-    (version "20171227")
+    (version "20190702")
     (source
      (origin
        (method git-fetch)
@@ -713,31 +713,18 @@ using password-store through rofi interface:
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1rzayv4ydxwb5fqyr1y8nz0wsb9r45mwl1wrq8hmikjrlqhhjn6f"))))
+         "01rwanr4wmr9vm6c712x411wig543q195z2icn388z892a93lc7p"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
-       #:make-flags '("CC=gcc"
-                      "OPTTEST=1")     ;disable CPU optimization
+       #:make-flags (list "CC=gcc"
+                          (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                          "LIBRARY_REL=lib"
+                          (string-append "ARGON2_VERSION=" ,version)
+                          "OPTTEST=1")  ; disable CPU optimization
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-Makefile
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (substitute* "Makefile"
-                 (("PREFIX = /usr") (string-append "PREFIX = " out)))
-               (substitute* "libargon2.pc"
-                 (("prefix=/usr") (string-append "prefix=" out))
-                 (("@HOST_MULTIARCH@") "")
-                 (("@UPSTREAM_VER@") ,version))
-               #t)))
-         (delete 'configure)
-         (add-after 'install 'install-argon2.pc
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (install-file "libargon2.pc"
-                             (string-append out "/lib/pkgconfig"))
-               #t))))))
+         (delete 'configure))))         ; No configure script.
     (home-page "https://www.argon2.com/")
     (synopsis "Password hashing library")
     (description "Argon2 provides a key derivation function that was declared