summary refs log tree commit diff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-22 12:39:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-22 14:17:31 +0200
commit54bcc27fb5fb1ecc9dca85380cb16913b3349d55 (patch)
tree707d2b5bc02d989ebcdfff500a9911be5bf9ea4e /gnu/packages/password-utils.scm
parentb70f9ad1654bb2e363257ff2365d56cce9f6f2e0 (diff)
downloadguix-54bcc27fb5fb1ecc9dca85380cb16913b3349d55.tar.gz
gnu: pass-git-helper: Run test suite.
* gnu/packages/password-utils.scm (pass-git-helper)[arguments]: Adjust
custom 'patch-pass-path phase. Use custom 'check phase.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 989d27a2e0..2716997049 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -768,13 +768,14 @@ winner of the 2015 Password Hashing Competition.")
            (lambda* (#:key inputs #:allow-other-keys)
              (let* ((password-store (assoc-ref inputs "password-store"))
                     (pass (string-append password-store "/bin/pass")))
-               (substitute* "passgithelper.py"
+               (substitute* '("passgithelper.py"
+                              "test_passgithelper.py")
                  (("'pass'") (string-append "'" pass "'")))
                #t)))
-         (add-before 'check 'pre-check
+         (replace 'check
            (lambda _
              (setenv "HOME" (getcwd))
-             #t)))))
+             (invoke "pytest"))))))
     (inputs
      `(("python-pyxdg" ,python-pyxdg)
        ("password-store" ,password-store)))