summary refs log tree commit diff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-09-03 14:08:26 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:10:13 +0200
commitaed1c2f794bb15c6b9058783fc60a19a69972b6f (patch)
tree20f43bab68352e56674f59bcc3a57b4b376c61b9 /gnu/packages/password-utils.scm
parent99afc7d65b2ff77790480f66dc769ee318774082 (diff)
downloadguix-aed1c2f794bb15c6b9058783fc60a19a69972b6f.tar.gz
gnu: hashcat: Rewrite with G-exps.
This is required for cross-compilation, as %output does not exist when
cross-compiling.

* gnu/packages/password-utils.scm (hashcat)[arguments]: Rewrite with G-exps.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 2c7156db93..343ec07ad5 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1132,20 +1132,18 @@ your online accounts makes it necessary.")
     (native-inputs (list opencl-headers))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                                ;no tests
-       #:make-flags (list (string-append "PREFIX=" %output)
-                          ;; TODO: unbundle
-                          ;; (string-append "USE_SYSTEM_LZMA=1")
-                          (string-append "USE_SYSTEM_ZLIB=1")
-                          (string-append "USE_SYSTEM_OPENCL=1")
-                          (string-append "USE_SYSTEM_XXHASH=1"))
-       #:phases (modify-phases %standard-phases
-                  ;; Don't embed timestamps, for bit-for-bit reproducibility.
-                  (add-after 'unpack 'fix-reproducibility
-                    (lambda _
-                      (substitute* "src/Makefile"
-                        (("\\$\\(shell date \\+%s\\)") "0"))))
-                  (delete 'configure))))
+     (list #:tests? #f ;no tests
+           #:make-flags #~(list (string-append "PREFIX=" #$output)
+                                (string-append "USE_SYSTEM_ZLIB=1")
+                                (string-append "USE_SYSTEM_OPENCL=1")
+                                (string-append "USE_SYSTEM_XXHASH=1"))
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'fix-reproducibility
+                          (lambda _
+                            (substitute* "src/Makefile"
+                              (("\\$\\(shell date \\+%s\\)")
+                               "0"))))
+                        (delete 'configure))))
     (home-page "https://hashcat.net/hashcat/")
     (synopsis "Advanced password recovery utility")
     (description