summary refs log tree commit diff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-28 02:35:09 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-28 02:34:07 +0100
commit2b9b4b1fe368fb1745c4150adbb8754948326c95 (patch)
treed637add71a2624a53762b445bfdb387d20f73436 /gnu/packages/password-utils.scm
parent2792d8a8652bbc017ee0be17cff33ee5968c9d41 (diff)
downloadguix-2b9b4b1fe368fb1745c4150adbb8754948326c95.tar.gz
gnu: hashcat-utils: Update to 1.9.
And trim lines to 80 characters.

* gnu/packages/password-utils.scm (hashcat-utils): Update to 1.9.
[source]: Parametrise.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index e09bbea5cc..357ef86d56 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -735,15 +735,15 @@ password cracking.")
 (define-public hashcat-utils
   (package
     (name "hashcat-utils")
-    (version "1.8")
+    (version "1.9")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://github.com/hashcat/hashcat-utils/releases/download/v"
-                           version "/hashcat-utils-1.8.7z"))
+       (uri (string-append "https://github.com/hashcat/hashcat-utils/releases/"
+                           "download/v" version "/"
+                           "hashcat-utils-" version ".7z"))
        (sha256
-        (base32
-         "1x80rngjz7gkhwplhw1iqr0wzb6hjkrjfld2kz9kmgp5dr9nys1p"))))
+        (base32 "0kq555kb338691qd7zjmi8vhq4km3apnsl2w63zh0igwzcjx6lx1"))))
     (native-inputs
      `(("p7zip" ,p7zip)))
     (inputs
@@ -767,12 +767,16 @@ password cracking.")
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (string-append (assoc-ref outputs "out") "/bin")))
                (mkdir-p out)
-               (for-each (lambda (file)
-                           (copy-file file (string-append out "/" (basename file ".bin"))))
-                         (find-files "." "\\.bin$"))
-               (for-each (lambda (file)
-                           (copy-file file (string-append out "/" (basename file ".pl"))))
-                         (find-files "../bin" "\\.pl$"))
+               (for-each
+                (lambda (file)
+                  (copy-file file (string-append out "/"
+                                                 (basename file ".bin"))))
+                (find-files "." "\\.bin$"))
+               (for-each
+                (lambda (file)
+                  (copy-file file (string-append out "/"
+                                                 (basename file ".pl"))))
+                (find-files "../bin" "\\.pl$"))
                #t))))))
     (home-page "https://github.com/hashcat/hashcat-utils/")
     (synopsis "Small utilities that are useful in advanced password cracking")