summary refs log tree commit diff
path: root/gnu/packages/patches/adb-libssl_11-compatibility.patch
diff options
context:
space:
mode:
authorGiovanni Biscuolo <g@xelera.eu>2021-08-12 18:09:02 +0200
committerLeo Famulari <leo@famulari.name>2021-07-27 12:34:57 -0400
commit05effbbfc2fc6223aafacf8a3cb2b2d970b6bb66 (patch)
treef19d1be80b2485635fe7f8d902f498dec18f1b53 /gnu/packages/patches/adb-libssl_11-compatibility.patch
parentef9dc9efa49a1db600805f3fbcd2dbfbabfb4ea4 (diff)
downloadguix-05effbbfc2fc6223aafacf8a3cb2b2d970b6bb66.tar.gz
gnu: adb: Make compatible with OpenSSL 1.1.
OpenSSL version 1.1 brought some API changes which broke the build here, fix
that by accessing rsa->n (and e) directly, using RSA_get0_key instead.

* gnu/packages/patches/adb-libssl_11-compatibility.patch: New file
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/android.scm (android-platform-system-core)[origin]: Use it.
(adb)[inputs]: Replace openssl-1.0 with openssl.
Diffstat (limited to 'gnu/packages/patches/adb-libssl_11-compatibility.patch')
-rw-r--r--gnu/packages/patches/adb-libssl_11-compatibility.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/adb-libssl_11-compatibility.patch b/gnu/packages/patches/adb-libssl_11-compatibility.patch
new file mode 100644
index 0000000000..9affe58b5d
--- /dev/null
+++ b/gnu/packages/patches/adb-libssl_11-compatibility.patch
@@ -0,0 +1,35 @@
+This patch is taken from Debian
+URL: https://sources.debian.org/data/main/a/android-platform-system-core/1%3A7.0.0%2Br33-1/debian/patches/adb_libssl_11.diff
+Description: adb: Make compatible with openssl 1.1
+ OpenSSL version 1.1 brought some API changes which broke the build here,
+ fix that by accessing rsa->n (and e) directly, using RSA_get0_key instead.
+Author: Chirayu Desai <chirayudesai1@gmail.com
+Last-Update: 2016-11-10
+--- a/adb/adb_auth_host.cpp
++++ b/adb/adb_auth_host.cpp
+@@ -71,6 +71,7 @@
+     BIGNUM* rem = BN_new();
+     BIGNUM* n = BN_new();
+     BIGNUM* n0inv = BN_new();
++    BIGNUM* e = BN_new();
+ 
+     if (RSA_size(rsa) != RSANUMBYTES) {
+         ret = 0;
+@@ -78,7 +79,7 @@
+     }
+ 
+     BN_set_bit(r32, 32);
+-    BN_copy(n, rsa->n);
++    RSA_get0_key(rsa, &n, &e, NULL);
+     BN_set_bit(r, RSANUMWORDS * 32);
+     BN_mod_sqr(rr, r, n, ctx);
+     BN_div(NULL, rem, n, r32, ctx);
+@@ -92,7 +93,7 @@
+         BN_div(n, rem, n, r32, ctx);
+         pkey->n[i] = BN_get_word(rem);
+     }
+-    pkey->exponent = BN_get_word(rsa->e);
++    pkey->exponent = BN_get_word(e);
+ 
+ out:
+     BN_free(n0inv);