summary refs log tree commit diff
path: root/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-10 14:48:02 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-10 16:02:51 +0200
commit523280e0993cf8bd6190c729e9cd18be52b73ab5 (patch)
treeaa863d8293e9bf637d36edd6205f85c0038c3935 /gnu/packages/patches/binutils-mingw-w64-deterministic.patch
parent1a24df44347629cd67821d672edad7636404f293 (diff)
downloadguix-523280e0993cf8bd6190c729e9cd18be52b73ab5.tar.gz
gnu: binutils: Shorten file names of MinGW patches.
This ensures we stay below the POSIX tar file name length limit.

* gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch:
Rename to...
* gnu/packages/patches/binutils-mingw-w64-deterministic.patch: ... this.
* gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch:
Rename to...
* gnu/packages/patches/binutils-mingw-w64-timestamp.patch: ... this.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/cross-base.scm (cross-binutils): Likewise.
Diffstat (limited to 'gnu/packages/patches/binutils-mingw-w64-deterministic.patch')
-rw-r--r--gnu/packages/patches/binutils-mingw-w64-deterministic.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/binutils-mingw-w64-deterministic.patch b/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
new file mode 100644
index 0000000000..3e48b87935
--- /dev/null
+++ b/gnu/packages/patches/binutils-mingw-w64-deterministic.patch
@@ -0,0 +1,22 @@
+This following patch was originally found at the debian mingw-w64 team's
+binutils repo located here:
+https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+  $ git show da63f6b:debian/patches/reproducible-import-libraries.patch
+
+Description: Make DLL import libraries reproducible
+Author: Benjamin Moody <benjamin.moody@gmail.com>
+Bug-Debian: https://bugs.debian.org/915055
+
+--- a/ld/pe-dll.c
++++ b/ld/pe-dll.c
+@@ -2844,6 +2844,7 @@
+ 
+   bfd_set_format (outarch, bfd_archive);
+   outarch->has_armap = 1;
++  outarch->flags |= BFD_DETERMINISTIC_OUTPUT;
+ 
+   /* Work out a reasonable size of things to put onto one line.  */
+   ar_head = make_head (outarch);