summary refs log tree commit diff
path: root/gnu/packages/patches/ceph-skip-unittest_blockdev.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-21 15:18:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-07 18:18:11 +0100
commitbe23ce2c7cdb696ff20f65750f939f316991e92f (patch)
tree05c0d5f90e9a9d32ef2e923fbb4aa01db4c2bfb7 /gnu/packages/patches/ceph-skip-unittest_blockdev.patch
parent2316f027f806965062fc842f0ad5be28582c54c5 (diff)
downloadguix-be23ce2c7cdb696ff20f65750f939f316991e92f.tar.gz
gnu: Ceph: Update to 14.2.5.
This also removes test-specific code to ease the Python 3 transition, and
because it is mostly obsolete.

* gnu/packages/patches/ceph-detect-rocksdb.patch,
gnu/packages/patches/ceph-skip-unittest_blockdev.patch,
gnu/packages/patches/ceph-skip-collect-sys-info-test.patch: Delete files.
* gnu/packages/patches/ceph-boost-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/storage.scm (ceph): Update to 14.2.5.
[source](patches): Adjust as above.
[source](snippet): Remove bundled "fmt", "c-ares" and "googletest".
[arguments]: Add "-DCMAKE_INSTALL_DATADIR" and "-DWITH_RADOSGW_AMQP_ENDPOINT"
and "-DWITH_TESTS" in #:configure-flags; remove "-DWITH_XIO".  Remove obsolete
substitutions.  Don't install 'ceph-disk' and 'ceph-detect-init', which no
longer exists.  Remove test-specific substitutions and phases.  Adjust for
Python 2->3 in inputs.
[native-inputs]: Remove INETUTILS, JQ, PERL, XMLSTARLET, PYTHON2-CRAM,
PYTHON2-VIRTUALENV, PYTHON2-CONFIGOBJ, PYTHON2-COVERAGE, PYTHON2-DISCOVER,
PYTHON2-FLAKE8, PYTHON2-MOCK, PYTHON2-NOSE, PYTHON2-PIP, PYTHON2-PYTEST,
PYTHON2-SUBUNIT PYTHON2-TESTREPOSITORY, PYTHON2-TESTTOOLS, and PYTHON2-TOX.
[inputs]: Change from BOOST to BOOST-WITH-PYTHON3.  Remove GPTFDISK, PARTED,
PYTHON-2, PYTHON2-SIX, PYTHON2-PRETTYTABLE, and PYTHON-3.  Add PYTHON-SIX,
PYTHON-PRETTYTABLE, PYTHON-WRAPPER, LIBCAP-NG, LIBNL, NCURSES, and RDMA-CORE.
Diffstat (limited to 'gnu/packages/patches/ceph-skip-unittest_blockdev.patch')
-rw-r--r--gnu/packages/patches/ceph-skip-unittest_blockdev.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/patches/ceph-skip-unittest_blockdev.patch b/gnu/packages/patches/ceph-skip-unittest_blockdev.patch
deleted file mode 100644
index 407bd93278..0000000000
--- a/gnu/packages/patches/ceph-skip-unittest_blockdev.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This test tries to walk a sysfs path and hits a null pointer exception.
-
-/tmp/guix-build-ceph-12.0.0.drv-0/ceph-12.0.0/src/test/common/test_blkdev.cc:32: Failure
-Expected: (dir) != (nullptr), actual: NULL vs 8-byte object <00-00 00-00 00-00 00-00>
-
-diff --git a/src/test/common/CMakeLists.txt b/src/test/common/CMakeLists.txt
---- a/src/test/common/CMakeLists.txt
-+++ b/src/test/common/CMakeLists.txt
-@@ -12,15 +12,6 @@
-   ${CMAKE_DL_LIBS}
-   )
- 
--if(HAVE_BLKID)
--  # unittest_blkdev
--  add_executable(unittest_blkdev
--    test_blkdev.cc
--    )
--  add_ceph_unittest(unittest_blkdev)
--  target_link_libraries(unittest_blkdev ceph-common ${BLKID_LIBRARIES})
--endif()
--
- # unittest_bloom_filter
- add_executable(unittest_bloom_filter
-   test_bloom_filter.cc