summary refs log tree commit diff
path: root/gnu/packages/patches/cpulimit-with-glib-2.32.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-21 23:39:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-21 23:39:43 -0400
commita9429c8f2207841c649438187d6e19046d323a16 (patch)
treea06e4b8a87b6a42742cf6750276746a10b6c2139 /gnu/packages/patches/cpulimit-with-glib-2.32.patch
parentf0136b36ae8c1e9c174043bd50e0e24413c0f345 (diff)
parent49b350fafc2c3ea1db66461b73d4e304cd13ec92 (diff)
downloadguix-a9429c8f2207841c649438187d6e19046d323a16.tar.gz
Merge branch 'staging' into core-updates.
Diffstat (limited to 'gnu/packages/patches/cpulimit-with-glib-2.32.patch')
-rw-r--r--gnu/packages/patches/cpulimit-with-glib-2.32.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/cpulimit-with-glib-2.32.patch b/gnu/packages/patches/cpulimit-with-glib-2.32.patch
new file mode 100644
index 0000000000..4c0bbaac7c
--- /dev/null
+++ b/gnu/packages/patches/cpulimit-with-glib-2.32.patch
@@ -0,0 +1,35 @@
+From 4a4794e041edf85cb67b9fbba66ad1a22fdcaaec Mon Sep 17 00:00:00 2001
+From: Eric Bavier <bavier@posteo.net>
+Date: Sat, 29 Jan 2022 00:10:20 -0600
+Subject: [PATCH] Fixes linux build with glibc-2.32.
+
+* cpulimit.c: Guard inclusion of <sys/sysctl.h> which is needed only for
+  __APPLE__ and is deprecated and unavailable starting with glibc-2.32.
+---
+ src/cpulimit.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Submitted upstream at https://github.com/opsengine/cpulimit/pull/105
+
+diff --git a/src/cpulimit.c b/src/cpulimit.c
+index 50eabea..be8cf22 100644
+--- a/src/cpulimit.c
++++ b/src/cpulimit.c
+@@ -38,13 +38,13 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+-#include <sys/sysctl.h>
+ #include <sys/resource.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ 
+ #ifdef __APPLE__ || __FREEBSD__
+ #include <libgen.h>
++#include <sys/sysctl.h>
+ #endif
+ 
+ #include "process_group.h"
+-- 
+2.34.0
+