summary refs log tree commit diff
path: root/gnu/packages/patches/cpulimit-with-glib-2.32.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-13 14:24:53 +0100
committerMarius Bakke <marius@gnu.org>2022-02-13 14:24:53 +0100
commit76b6bbdf232b4b82cdd23cfe0d81331a4fd2edec (patch)
tree0e6a57ba08b9c6f9f5cbcdc5b5d9daeea91e428d /gnu/packages/patches/cpulimit-with-glib-2.32.patch
parent1a5302435ff0d2822b823f5a6fe01faa7a85c629 (diff)
parente8af2ea63a7f497b8f8e19e206645109c0646e72 (diff)
downloadguix-76b6bbdf232b4b82cdd23cfe0d81331a4fd2edec.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/cpulimit-with-glib-2.32.patch')
-rw-r--r--gnu/packages/patches/cpulimit-with-glib-2.32.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/cpulimit-with-glib-2.32.patch b/gnu/packages/patches/cpulimit-with-glib-2.32.patch
new file mode 100644
index 0000000000..4c0bbaac7c
--- /dev/null
+++ b/gnu/packages/patches/cpulimit-with-glib-2.32.patch
@@ -0,0 +1,35 @@
+From 4a4794e041edf85cb67b9fbba66ad1a22fdcaaec Mon Sep 17 00:00:00 2001
+From: Eric Bavier <bavier@posteo.net>
+Date: Sat, 29 Jan 2022 00:10:20 -0600
+Subject: [PATCH] Fixes linux build with glibc-2.32.
+
+* cpulimit.c: Guard inclusion of <sys/sysctl.h> which is needed only for
+  __APPLE__ and is deprecated and unavailable starting with glibc-2.32.
+---
+ src/cpulimit.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Submitted upstream at https://github.com/opsengine/cpulimit/pull/105
+
+diff --git a/src/cpulimit.c b/src/cpulimit.c
+index 50eabea..be8cf22 100644
+--- a/src/cpulimit.c
++++ b/src/cpulimit.c
+@@ -38,13 +38,13 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+-#include <sys/sysctl.h>
+ #include <sys/resource.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ 
+ #ifdef __APPLE__ || __FREEBSD__
+ #include <libgen.h>
++#include <sys/sysctl.h>
+ #endif
+ 
+ #include "process_group.h"
+-- 
+2.34.0
+