summary refs log tree commit diff
path: root/gnu/packages/patches/csound-header-ordering.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-05 16:09:27 -0600
committerLudovic Courtès <ludo@gnu.org>2016-01-12 21:07:53 +0100
commitc91d3fb7f4f754b56b540d8556d6a3ce6085ef37 (patch)
tree89c7d1ff32dcf730de4c26033b8ea1786395129e /gnu/packages/patches/csound-header-ordering.patch
parent3abe8136fddf5bed75219bcb8a552004f078560a (diff)
downloadguix-c91d3fb7f4f754b56b540d8556d6a3ce6085ef37.tar.gz
gnu: boost: Update to 1.60.0.
* gnu/packages/boost.scm (boost): Update to 1.60.0.
  [source]: Remove patch.
* gnu/packages/patches/boost-mips-avoid-m32.patch: Delete patch
* gnu-system.am (dist_patch_DATA): Remove patch.

Also fix dependent packages:

* gnu/packages/patches/csound-header-ordering.patch: New patch.
* gnu/packages/audio.scm (csound)[source]: Use it.
  [arguments]: Add 'set-flags phase.
* gnu/packages/patches/libcmis-fix-test-onedrive.patch: New patch.
* gnu/packages/libreoffice.scm (libcmis)[source]: Use it.
  (libreoffice)[arguments]: Add LDFLAGS to #:configure-flags.
  (librevenge)[inputs]: Move boost from here...
  [propogated-inputs]: to here.
  [arguments]: Add LDFLAGS to #:configure-flags.
* gnu/packages/patches/openimageio-boost-1.60.patch: New patch.
* gnu/packages/graphics.scm (openimageio): Use it.
* gnu-system.am (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/patches/csound-header-ordering.patch')
-rw-r--r--gnu/packages/patches/csound-header-ordering.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/csound-header-ordering.patch b/gnu/packages/patches/csound-header-ordering.patch
new file mode 100644
index 0000000000..3640d123dd
--- /dev/null
+++ b/gnu/packages/patches/csound-header-ordering.patch
@@ -0,0 +1,20 @@
+Prevent compilation issues with boost-1.60.0.
+
+Reported upstream at https://github.com/csound/csound/issues/570
+
+--- Csound6.05/Opcodes/chua/ChuaOscillator.cpp	2015-04-25 14:06:22.995646234 -0500
++++ Csound6.05/Opcodes/chua/ChuaOscillator.cpp	2015-12-21 10:31:58.182362640 -0600
+@@ -117,11 +117,12 @@
+ //     d = sys_variables(12);
+ //     gnor = a*(x.^3) + b*(x.^2) + c*x + d;
+ 
+-#include <OpcodeBase.hpp>
+ #include <boost/numeric/ublas/vector.hpp>
+ using namespace boost::numeric;
+ #include <cmath>
+ 
++#include <OpcodeBase.hpp>
++
+ #undef CS_KSMPS
+ #define CS_KSMPS     (opds.insdshead->ksmps)
+