summary refs log tree commit diff
path: root/gnu/packages/patches/cssc-gets-undeclared.patch
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-05-27 21:38:47 +0200
committerJohn Darrington <jmd@gnu.org>2014-05-28 18:50:00 +0200
commit25f76ef0bae59fc7da6f1e0d4f62ec9e5f75ee94 (patch)
tree6e200a60db0115fc9a8ec4857bc4561405c06d0f /gnu/packages/patches/cssc-gets-undeclared.patch
parent93c3de921ad5ce5eeb52b0f0f1643e6c4158574f (diff)
downloadguix-25f76ef0bae59fc7da6f1e0d4f62ec9e5f75ee94.tar.gz
gnu: Add cssc.
* gnu/packages/version-control.scm (cssc): New variable.
* gnu/packages/patches/cssc-gets-undeclared.patch: New file
* gnu/packages/patches/cssc-missing-include.patch: New file
* gnu-system.am: Add gnu/packages/patches/cssc-gets-undeclared.patch
  and gnu/packages/patches/cssc-missing-include.patch
Diffstat (limited to 'gnu/packages/patches/cssc-gets-undeclared.patch')
-rw-r--r--gnu/packages/patches/cssc-gets-undeclared.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/cssc-gets-undeclared.patch b/gnu/packages/patches/cssc-gets-undeclared.patch
new file mode 100644
index 0000000000..68c607cf58
--- /dev/null
+++ b/gnu/packages/patches/cssc-gets-undeclared.patch
@@ -0,0 +1,17 @@
+CSSC uses a gets in a couple of places.  For security reasons, modern gnulib
+does not allow this.  This patch allows it again.
+--- CSSC-1.3.0/gl/lib/stdio.in.h	2010-05-15 00:15:35.000000000 +0200
++++ CSSC-1.3.0/gl/lib/stdio.in.h	2014-02-03 21:27:10.000000000 +0100
+@@ -135,12 +135,6 @@
+                  "use gnulib module fflush for portable POSIX compliance");
+ #endif
+ 
+-/* It is very rare that the developer ever has full control of stdin,
+-   so any use of gets warrants an unconditional warning.  Assume it is
+-   always declared, since it is required by C89.  */
+-#undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+ #  if !(defined __cplusplus && defined GNULIB_NAMESPACE)