summary refs log tree commit diff
path: root/gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-20 17:40:43 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-01-02 17:01:07 +0100
commit0f72f0523878361df9c57078c68958689a41b513 (patch)
tree7c9b80d8ddf5b846e793c4e634df064752b8649f /gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch
parent0c86790bfdf5a3e61bff6e289c1dcef16154a27b (diff)
downloadguix-0f72f0523878361df9c57078c68958689a41b513.tar.gz
gnu: docbook-xsl: Disable recursion in string substitution.
Fixes <https://bugs.gnu.org/29782>.
Reported by Gábor Boskovits.

* gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/docbook.scm (docbook-xsl)[source](patches): Use it.
[native-inputs]: Add XZ.
[arguments]: Adjust PATH accordingly.
Diffstat (limited to 'gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch')
-rw-r--r--gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch b/gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch
new file mode 100644
index 0000000000..4199dd18a5
--- /dev/null
+++ b/gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch
@@ -0,0 +1,39 @@
+Use a non-recursive replace function when the parser supports it.
+
+https://bugs.gnu.org/29782
+https://bugzilla.samba.org/show_bug.cgi?id=9515
+https://bugzilla.gnome.org/show_bug.cgi?id=736077 (for xsltproc)
+
+Patch copied from Debian:
+https://anonscm.debian.org/cgit/collab-maint/docbook-xsl.git/tree/debian/patches/765567_non-recursive_string_subst.patch
+
+Description: use EXSLT "replace" function when available
+ A recursive implementation  of string.subst is problematic,
+ long strings with many matches will cause stack overflows.
+Author: Peter De Wachter <pdewacht@gmail.com>
+Bug-Debian: https://bugs.debian.org/750593
+
+--- a/lib/lib.xsl
++++ b/lib/lib.xsl
+@@ -10,7 +10,10 @@
+      This module implements DTD-independent functions
+ 
+      ******************************************************************** -->
+-<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
++<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
++                xmlns:str="http://exslt.org/strings"
++                exclude-result-prefixes="str"
++                version="1.0">
+ 
+ <xsl:template name="dot.count">
+   <!-- Returns the number of "." characters in a string -->
+@@ -56,6 +59,9 @@
+   <xsl:param name="replacement"/>
+ 
+   <xsl:choose>
++    <xsl:when test="function-available('str:replace')">
++      <xsl:value-of select="str:replace($string, string($target), string($replacement))"/>
++    </xsl:when>
+     <xsl:when test="contains($string, $target)">
+       <xsl:variable name="rest">
+         <xsl:call-template name="string.subst">