summary refs log tree commit diff
path: root/gnu/packages/patches/doxygen-gcc-ice.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-22 16:45:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-22 18:01:09 +0200
commitfb76ef8477f189d35c1e91bf026236f5627f3a27 (patch)
treef4984214a0f32d8005c7c067e887bac9d70a29d1 /gnu/packages/patches/doxygen-gcc-ice.patch
parentbf91e6835d21e3bd7b49bb85b40f61389604c6f7 (diff)
downloadguix-fb76ef8477f189d35c1e91bf026236f5627f3a27.tar.gz
gnu: Remove GCC ICE workarounds.
* gnu/packages/patches/doxygen-gcc-ice.patch,
gnu/packages/patches/mariadb-gcc-ice.patch,
gnu/packages/patches/perf-gcc-ice.patch: Delete files
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/databases.scm (mariadb)[source](patches): Likewise.
* gnu/packages/linux.scm (perf)[source](patches): Likewise.
* gnu/packages/documentation.scm (doxygen)[inputs, arguments]: Likewise.
Diffstat (limited to 'gnu/packages/patches/doxygen-gcc-ice.patch')
-rw-r--r--gnu/packages/patches/doxygen-gcc-ice.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/patches/doxygen-gcc-ice.patch b/gnu/packages/patches/doxygen-gcc-ice.patch
deleted file mode 100644
index fbfedcb7ab..0000000000
--- a/gnu/packages/patches/doxygen-gcc-ice.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Work around this GCC ICE: <https://bugs.gnu.org/31708>.  It shows up
-only when doing native compiles on armhf-linux.
-
-Yes it's a terrible patch, but it does the job.
-
---- doxygen-1.8.13/qtools/qutfcodec.cpp	1970-01-01 01:00:00.000000000 +0100
-+++ doxygen-1.8.13/qtools/qutfcodec.cpp	2018-06-08 14:14:29.614009929 +0200
-@@ -189,7 +189,7 @@ int QUtf16Codec::heuristicContentMatch(c
- }
- 
- 
--
-+volatile const void *bomPointer = &QChar::byteOrderMark;
- 
- class QUtf16Encoder : public QTextEncoder {
-     bool headerdone;
-@@ -209,7 +209,7 @@ public:
- 	    headerdone = TRUE;
- 	    len_in_out = (1+uc.length())*(int)sizeof(QChar);
- 	    QCString d(len_in_out);
--	    memcpy(d.rawData(),&QChar::byteOrderMark,sizeof(QChar));
-+	    memcpy(d.rawData(),(void *)bomPointer,sizeof(QChar));
- 	    memcpy(d.rawData()+sizeof(QChar),uc.unicode(),uc.length()*sizeof(QChar));
- 	    return d;
- 	}