summary refs log tree commit diff
path: root/gnu/packages/patches/doxygen-tmake.patch
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-25 00:03:36 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-25 00:03:36 +0200
commit436d4d1fbb425c26d716e9f789f1284ec088cc86 (patch)
tree42ca76a36038b78eef50666293b65a29a02a4a62 /gnu/packages/patches/doxygen-tmake.patch
parentc0412fedf85034d9e00e84e5ae5c415df1df6284 (diff)
downloadguix-436d4d1fbb425c26d716e9f789f1284ec088cc86.tar.gz
gnu: Add doxygen.
* gnu/packages/doxygen.scm: New file.
* gnu/packages/patches/doxygen-test.patch,
  gnu/packages/patches/doxygen-tmake.patch: New files.
* gnu-system.am (GNU_SYSTEM_MODULES, dist_patch_DATA): Register the new files.
Diffstat (limited to 'gnu/packages/patches/doxygen-tmake.patch')
-rw-r--r--gnu/packages/patches/doxygen-tmake.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/doxygen-tmake.patch b/gnu/packages/patches/doxygen-tmake.patch
new file mode 100644
index 0000000000..3579243702
--- /dev/null
+++ b/gnu/packages/patches/doxygen-tmake.patch
@@ -0,0 +1,24 @@
+Fix the `check_unix' function, which looks for `/bin/uname' to determine
+whether we're on a Unix-like system.
+Taken from nixpkgs.
+
+--- doxygen-1.5.8/tmake/bin/tmake	2008-12-06 14:16:20.000000000 +0100
++++ doxygen-1.5.8/tmake/bin/tmake	2009-03-05 11:29:55.000000000 +0100
+@@ -234,17 +234,7 @@ sub tmake_verb {
+ #
+ 
+ sub check_unix {
+-    my($r);
+-    $r = 0;
+-    if ( -f "/bin/uname" ) {
+-	$r = 1;
+-	(-f "\\bin\\uname") && ($r = 0);
+-    }
+-    if ( -f "/usr/bin/uname" ) {
+-	$r = 1;
+-	(-f "\\usr\\bin\\uname") && ($r = 0);
+-    }
+-    return $r;
++    return 1;
+ }
+