summary refs log tree commit diff
path: root/gnu/packages/patches/e9patch-check-same_op_2.patch
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2024-08-07 13:18:46 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2024-11-18 17:19:20 +0900
commit3e4807dad3008fd8afc4759f57ecdb5cf9b1ed2e (patch)
tree6e549d36aa7da32c46f83c7d4e803c51d7d6490d /gnu/packages/patches/e9patch-check-same_op_2.patch
parentb0416b8503e38746717a2d1167f9d1410634981e (diff)
downloadguix-3e4807dad3008fd8afc4759f57ecdb5cf9b1ed2e.tar.gz
gnu: Add e9patch. e9patch
* gnu/packages/engineering.scm (e9patch): New variable.
* gnu/packages/patches/e9patch-check-intel-format.patch: Add file.
* gnu/packages/patches/e9patch-check-mode.patch: Add file.
* gnu/packages/patches/e9patch-check-mov-imm.patch: Add file.
* gnu/packages/patches/e9patch-check-rflags.patch: Add file.
* gnu/packages/patches/e9patch-check-same_op_2.patch: Add file.
* gnu/packages/patches/e9patch-check.patch: Add file.
* gnu/packages/patches/e9patch-devendor.patch: Add file.
* gnu/packages/patches/e9patch-plugin-api-headers.patch: Add file.
* gnu/local.mk (dist_patch_DATA): Register patches.

Change-Id: I8da4e76043bf6d577e8d14a89cc7bc35caa3933f
Diffstat (limited to 'gnu/packages/patches/e9patch-check-same_op_2.patch')
-rw-r--r--gnu/packages/patches/e9patch-check-same_op_2.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/e9patch-check-same_op_2.patch b/gnu/packages/patches/e9patch-check-same_op_2.patch
new file mode 100644
index 0000000000..f87285a8ac
--- /dev/null
+++ b/gnu/packages/patches/e9patch-check-same_op_2.patch
@@ -0,0 +1,21 @@
+From d457613c546e1e936440d4a9085f5dfea9a76f0a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Nguy=E1=BB=85n=20Gia=20Phong?= <cnx@loang.net>
+Date: Mon, 18 Nov 2024 15:59:15 +0900
+Subject: [PATCH] Fix same_op_2 test expectation
+
+---
+ test/regtest/same_op_2.exp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/test/regtest/same_op_2.exp b/test/regtest/same_op_2.exp
+index f99033a..45790b8 100644
+--- a/test/regtest/same_op_2.exp
++++ b/test/regtest/same_op_2.exp
+@@ -12,6 +12,7 @@ shl $0x7, %rdi
+ sar $0x3, %rdi
+ pxor %xmm0, %xmm0
+ cvtsi2ss %rax, %xmm0
++sqrtss %xmm0, %xmm1
+ xor %esi, %esi
+ xor %eax, %eax
+ PASSED