summary refs log tree commit diff
path: root/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 19:10:17 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2018-05-28 19:10:17 +0200
commita338b6f51d185cf80d387d3c20a96d89c53d45e7 (patch)
tree4f5354abaee8a4844bf2592cf1654c2cc7e0f8e2 /gnu/packages/patches/emacs-fix-scheme-indent-function.patch
parentbb82c3d42bb95588f40394f4d71f915654c0e643 (diff)
downloadguix-a338b6f51d185cf80d387d3c20a96d89c53d45e7.tar.gz
Revert "gnu: emacs: Update to 26.1."
This reverts commit bb82c3d42bb95588f40394f4d71f915654c0e643. This commit
needs probably to be done on core-updates.
Diffstat (limited to 'gnu/packages/patches/emacs-fix-scheme-indent-function.patch')
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
index 4b7904ea3b..c5a426802c 100644
--- a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
 
 --- a/lisp/progmodes/scheme.el
 +++ b/lisp/progmodes/scheme.el
-@@ -494,6 +494,12 @@ indentation."
-                         (> (length function) 3)
-                         (string-match "\\`def" function)))
-                (lisp-indent-defform state indent-point))
+@@ -482,6 +482,12 @@
+ 			(> (length function) 3)
+ 			(string-match "\\`def" function)))
+ 	       (lisp-indent-defform state indent-point))
 +              ((and (null method)
 +                    (> (length function) 1)
 +                    ;; The '#' in '#:' seems to get lost, not sure why
 +                    (string-match "\\`:" function))
 +               (let ((lisp-body-indent 1))
 +                 (lisp-indent-defform state indent-point)))
-               ((integerp method)
-                (lisp-indent-specform method state
-                                      indent-point normal-indent))
+ 	      ((integerp method)
+ 	       (lisp-indent-specform method state
+ 				     indent-point normal-indent))